Не работает маршрутизация при создании PPTP клиент-сервер

SafeStream беспроводной широкополосный гигабитный VPN-маршрутизатор серии N
yaskovit
Сообщения: 1
Зарегистрирован: 01 окт 2015, 11:34
Страна: Россия

Не работает маршрутизация при создании PPTP клиент-сервер

Сообщение yaskovit » 01 окт 2015, 12:26

Аппаратная версия устройства: 1.0
Версия прошивки: 1.1.0 Build 20141031 Rel.32628s
Ваша страна: Россия
Название провайдера: МТС
Тип подключения: 3G Dynamic IP
Скорость по тарифу: 10 Мбит/с
Подключение с ПК по wifi или по кабелю?: по кабелю
Наблюдается проблема, когда нет нагрузки?: да
Что пишется в статусе Вашего подключения при проблеме?: подключен
Наблюдается ли проблема при подключении без роутера?: нет
Ваша операционная система: WIN 7
Изображение



Есть 3G LTE роутер huawei CPE B593(192.168.3.1), с симкой МТС, раздает инет, за ним стоит TP-Link(WAN 192.168.3.2, LAN 192.168.0.0/24), на котором настроен PPTP туннель , клиент-сервер, TP-Link в роли клиента, удаленная сеть 192.168.77.0/27. Туннель поднимается, не видит удаленную сеть с ноутбука, подключенного к TP-Link'у, пингуется только ip, выданный VPN-сервером TP-Link'у, т.е. даже не пингуется внутренний адрес самого впн-сервера, к которому поднят впн-туннель, соответственно и маршруты не работают. При исключении из связки TP-Link'а , и создании подключения VPN из ОС, все работает. Может маршрут какой надо статический прописать? но как я понял, он сам пишет маршрут, когда указана Remote subnet...


Upd: Попробовал воткнуть шнурок нормального провайдера в сам роутер, ситуация не изменилась...
Vladr
Сообщения: 34
Зарегистрирован: 16 сен 2015, 10:49
Страна: Россия

Re: Не работает маршрутизация при создании PPTP клиент-серве

Сообщение Vladr » 03 ноя 2015, 23:13

Да. Тоже наткнулся на эту проблему.

Есть ЛАН за ZyXel Keenetic II 192.168.1.0/24
и ЛАН за TP-Link 192.168.5.0/24
На ZyXel поднят PPTP-сервер (PPTP Lan-to-Lan между ZyXel и TP-Link не получился)
На TP-Link создаю PPTP Client-to-Lan туннель к ZyXel
В итоге роутинг такой же как у ТС и с хоста, например, 192.168.5.30 я не могу пинговать даже шлюз подсети 192.168.1.0, не говоря уже о каком-либо из хостов этой подсети.
Пробовал и на ZyXel прописывать маршруты (хотя это неправильно, т.к. там нет интерфейса в поднятый туннель) и на TP-Link как до "белого" IP ZyXel на порту WAN так и до шлюза 192.168.1.1 в поле Next Hop настройки статического маршрута...
mesb
Сообщения: 119
Зарегистрирован: 25 авг 2012, 17:12
Страна: Россия

Re: Не работает маршрутизация при создании PPTP клиент-серве

Сообщение mesb » 04 ноя 2015, 10:31

Поднял щас центось, на ней poptop, тплинк лезет на неё, между ними адресация 10.0.0.1 - центось. 10.0.0.100 - тплинк.
На тплинке в качестве ремоута вообще вся 10.0.0.0/8.
На центоси дописал роут на сетку за тплинком через ип которой ему выдал поптоп.

По крайней мере центось после этого без проблем пинговала хост за тплинком.
Vladr
Сообщения: 34
Зарегистрирован: 16 сен 2015, 10:49
Страна: Россия

Re: Не работает маршрутизация при создании PPTP клиент-серве

Сообщение Vladr » 04 ноя 2015, 14:12

Когда на TP-Link поднят PPTP сервер и к нему коннектится клиент, то сеть за TP-Link видна. А вот когда TP-Link выступает в качестве PPTP клиента в к другому серверу, сеть, которую сервер отдает TP-Link-у как клиенту, за ним уже не видна.
Коннектился к удаленному ZyXel-серверу с ноута, создав VPN-туннель, работает и сеть за ним видна. Коннектился, подняв на другом ZyXel клиентский туннель к ZyXel-серверу и пинговал удаленную сеть - работает. Та же схема с TP-Link не хочет работать.
Еще раз. Есть
ZyXel PPTP-сервер. Z1 (192.168.1.0/24)
ZyXel PPTP-клиент Z2 (192.168.2.0/24)
TP-Link PPTP-клиент Т (192.168.3.0/24)
Из подсети за Z2 видна подсеть за Z1
А вот из подсети за Т не видна подсеть за Z1. Ну и сам шлюз Z1 не виден.
При этом на Z1 VPN-сервер показывает, что оба туннеля подняты. На туннеле Z2-Z1 видна активность, на туннеле T-Z1 трафик на соединение прошел и все, больше активности нет

Если на Z1 поднять клиента, а на Т сервер, то из подсети Z1 становится видна подсеть Т. Но у меня задача-то другая, из подсети Т увидеть подсеть Z1
mesb
Сообщения: 119
Зарегистрирован: 25 авг 2012, 17:12
Страна: Россия

Re: Не работает маршрутизация при создании PPTP клиент-серве

Сообщение mesb » 04 ноя 2015, 14:23

Ага, примерно понял что где, вместо Z1 у меня центось с poptop сервером.
Щас пока время есть немного подниму за ней клиентскую центось в сетку 192.168.1.0.
У меня только за T сетка чуть иная, 192.168.4.0 будет.
mesb
Сообщения: 119
Зарегистрирован: 25 авг 2012, 17:12
Страна: Россия

Re: Не работает маршрутизация при создании PPTP клиент-серве

Сообщение mesb » 04 ноя 2015, 15:01

И так, погнали:
centosclient(192.168.1.10) - (192.168.1.1)centospptpserver(11.22.33.44)(10.0.0.1) - (10.0.0.100)(44.33.22.11)tplink(192.168.4.1) - (192.168.4.110)testdevice

На centospptpserver
В настройках pptp такие адреса:
10.0.0.1 - сервер на центоси.
10.0.0.100 - словил тплинк когда обратился к центоси по pptp.

На центоси обязателен роут:
route add -net 192.168.4.0/24 gw 10.0.0.100

На тплинке при создании пптп аккаунта указано что удалённая сетка:
192.168.1.0/24

Машины: centosclient и testdevice друг друга пингуют.
У centosclient дефолт гейтвей 192.168.1.1.
У testdevice дефолт гейтвей 192.168.4.1.

Как итог считаю что тплинк внорме, я сомневаюсь что мне китайцы в бета прошивке что-то исправляли помимостабильности пптп сервера.
Надо внимательно смотреть роуты с обеих сторон, а также на клиентах за оными.
Vladr
Сообщения: 34
Зарегистрирован: 16 сен 2015, 10:49
Страна: Россия

Re: Не работает маршрутизация при создании PPTP клиент-серве

Сообщение Vladr » 04 ноя 2015, 19:36

mesb писал(а):И так, погнали:
centosclient(192.168.1.10) - (192.168.1.1)centospptpserver(11.22.33.44)(10.0.0.1) - (10.0.0.100)(44.33.22.11)tplink(192.168.4.1) - (192.168.4.110)testdevice


как у меня
хост(192.168.1.10) - (192.168.1.1)ZyXelPPTPserver(80.xxx.xxx.xx) - (78.xxx.xxx.xxx)TP-Link PPTPclient(192.168.100.1) - (192.168.100.5)testdevice

testdevice> ping 192.168.1.10 -> не пингуется
testdevice> ping 192.168.1.1 -> не пингуется

одновременно на на Zyxel (80.xxx.xxx.xxx) поднят второй туннель

хост(192.168.1.10) - (192.168.1.1)ZyXelPPTPserver(80.xxx.xxx.xx) - (37.xxx.xxx.xxx)ZyXel PPTPclient(192.168.101.1) - (192.168.101.5)testdevice2

testdevice2> ping 192.168.1.10 -> Ok
testdevice2> ping 192.168.1.1 -> Ok

ну и как следствие, доступна вся подсеть 192.168.1.0/24

ZyXel (80.xxx.xxx.xxx) - Keenetic Giga II
ZyXel (37.xxx.xxx.xxx) - Keenetic Giga - здесь VPN сервера нет в функционале, можно только клиентский туннель поднимать до другого VPN сервера.

С ZyXel (37.xxx.xxx.xxx) так же поднят туннель до TP-Link (есть так же аккаунт с PPTP сервером). Соответственно подсеть 192.168.100.0/24 доступна. А вот в обратную сторону не получается.
Вот таблица маршрутов http://www.floomby.ru/s2/hUkhFW
Boris
Сообщения: 378
Зарегистрирован: 05 май 2012, 11:40
Страна: Россия
Откуда: Москва

Re: Не работает маршрутизация при создании PPTP клиент-серве

Сообщение Boris » 04 ноя 2015, 21:26

Если исходить из 2х основных пунктов:

1. На 604W абсолютно рабочий PPPTP-клиент
2. Чудес не бывает

На Зикселе вообще ни одного слова нет о настройке LAN-to-LAN, следовательно, вероятнее всего эта железка работает изначально в режиме Client-to-LAN.
Мануал по настройке зюкселя
Обрати внимание на трансляцию NAT-пакетов, которую надо включать отдельно. И ещё на:
Внимание! Указываемая подсеть IP-адресов не должна совпадать или пересекаться с IP-адресами интерфейсов Keenetic, статическими IP-адресами подключенных устройств и используемыми на интерфейсах DHCP-пулами. При пересечении пулов адресов PPTP-сервера и, например, подсети Home клиент локальной сети может получить адрес, уже занятый в сети PPTP. Это приведет к ситуации, когда локальный хост не будет иметь доступа ни к Интернету (включая ping), ни к управлению интернет-центром Keenetic. При этом использовать одну и ту же подсеть IP-адресов не запрещено, если диапазоны IP-адресов PPTP-клиентов и клиентов локальной сети не будут пересекаться (например, указание диапазона 192.168.1.10-192.168.1.20 для PPTP-сервера и 192.168.1.33-192.168.1.52 для Home при использовании маски 24 бита вполне допустимо).


Чтобы всё нормально работало, тебе надо поменять местами 604 и гига2. Таким образом, 604 будет выступать в роли полноценного PPTP-сервера LAN-to-LAN, к нему будут цепляться твои два зюхеля.

Это кстати касается и автора этой темы. Нужно чётко понимать, что такое LAN-to-LAN, и что такое Client-to-LAN
Мои модели:
TL-ER604W
TL-MR3420
TL-WDR3600

Помогу с настройкой TP-LINK. Пишите в ЛС.
Vladr
Сообщения: 34
Зарегистрирован: 16 сен 2015, 10:49
Страна: Россия

Re: Не работает маршрутизация при создании PPTP клиент-серве

Сообщение Vladr » 04 ноя 2015, 23:21

Да, в Зухеле нет LAN-to-LAN.

Я не говорю, что клиент нерабочий, в связке с Зухелем не хочет что-то работать полноценно. Никак не получается победить. По таблице маршрутов при активации туннеля PPTP Client-to-LAN на TP-Link появляются два маршрута 7 и 8.
Из своей подсети (192.168.100.0) пингуется только адрес, который присвоен Зухелем TP-Link-у как клиенту той подсети, присвоив адрес из пула, определенного для VPN-сервера в Зухеле. Адреса не пересекаются ни с пулом адресов DHCP ни с пулом адресов Wi-Fi. Здесь все проверено и перепроверено. Я даже задал статику в конфигурации VPN-сервера на Зухеле для пользователя, под которым создается туннель с TP-Link.
Этот адрес пробовал использовать при создании статического маршрута на TP-Link, чтобы указать в Next Hop

Менять местами не вариант, т.к. на той площадке, где стоит Кинетик-2, другого и не надо, другая контора.
У меня стоит TP-LINK, т.к. мне нужен IPSec в четвертую подсеть. Там стоит Cisco и местный админ не будет только для меня поднимать PPTP. Не покупал, мне его работодатель поставил.

В сторону кинетика хотел получить рабочий туннель на роутере, но пока приходится использовать поднятие VPN в Винде, менее удобно. Была идея оттуда в свою забирать бекапы.
mesb
Сообщения: 119
Зарегистрирован: 25 авг 2012, 17:12
Страна: Россия

Re: Не работает маршрутизация при создании PPTP клиент-серве

Сообщение mesb » 05 ноя 2015, 08:47

Вот мои вариации:

Код: Выделить всё

1   0.0.0.0/0          44.33.22.1     GS       eth1    WAN1   0
2   10.0.0.1                N/A           HP   pptp-vpn-0    WAN1   2
3   44.33.22.11/30      N/A       C       eth1    WAN1   0
4   192.168.1.0/24    10.0.0.1       S   pptp-vpn-0    WAN1   0
5   192.168.4.0/24      N/A              CP        eth0   LAN   0


Сравнивайте.
Сдаётся мне, у вас косяк с адресацией, всё-таки в vpn тоннеле адреса надо делать отличными от локалки кмк.
А у вас как-то странно это выглядит.

Вернуться в «TL-ER604W»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость